0
À l'étude

Direct 3D11 Shader not being rendered in Game view (only scene view)

Julian Allescher il y a 7 ans mis à jour il y a 7 ans 2
Sorry for bothering you with my problems so often Joachim,

I've built a (IMO) very simple shader with reflective transparency, which works fine in scene/editor view. On the other hand, in Game view the material is not visible at all. I found out it has something to do with "Shader Settings" -> "Target renderer". When unchecking "Direct3D 11" the material becomes visible in GameView, but missing the effects I was trying to achieve.

This isn't the only shader I made that is struggling with this issue. What am I doing wrong? And how can I fix it?
Is there a way to have this material visible in Gameview while having "Direct 3D11" checked?

Direct 3D 11 checked:



Direct 3D 11 unchecked:






À l'étude
I'm guessing you may be forcing DX11 somewhere? Have an extra look at your quality settings and player settings. Also, you have a warning in the console.
Warning said: "Your shader might not render properly on your workstation - you need to have Direct3D 11 enabled when working in DX11 mode on Windows. Click the icon to enable Direct3D 11!" So not really helpful for me... :D Quality/Player settings didn't help much either.

But I found a way to overcome my problem:
I just duplicated the ".shader"-file in my explorer folder and also created a new material using that duplicated shader. For some reasons the new material finally displays in the game window.
The old shader still won't display though.

Don't know if it's a Unity or Shaderforge Bug, I leave this info here anyway :D