0
Under review

Can't use vertex data in channel mix?

brum 1 year ago • updated 1 year ago 5

I'm trying to do splat mapping via vertex color data. Seems like this should be all fine and dandy, but channel mixer only accepts a vector3 or a vector4 (for RGBA mask).

Since vertex color can contain an alpha channel, I'm trying to use it as an input just like you'd use a splat map, but it seems like you can't create a vector4 with custom inputs, just manual ones.

There are 2 types of vector4 nodes but you can't assign values to any of them via nodes, only manually, and i don't understand why.


I tried to code it up, but i get a constant error code when i input it into the mask.


Error code http://pastebin.com/5i3XwDxf


Any help would be greatly appreciated.

Not a bug

Use the append node, and append RGB with A, and you'll get a float4

Although it's a bit weird that you're getting an error from it

I tried what you suggested, i'm getting the same errors.

http://pastebin.com/E847YYvc


I don't know what i'm doing wrong, here is the node:

As soon as i plug in either my custom node or the append note into the mask, the program just completely breaks and runs at 1fps, while getting 10 errors a second.

My vertex colors do have alpha.

Under review

Yeah that's not good, reopening this

The Acol property doesn't seem to show up even if i plug an RGBA Texture2D into the mask field, but it doesn't throw errors like it does with vertex colors.

I've looked at the advanced splatmap tutorial, i assume you could achieve the height blending effect 4 textures using channel blend + vertex colors + height maps?