0
Fixed

Editor won't open in 5.6

Keenan Woodall 9 months ago • updated by Zack Black 4 weeks ago 4

I'm using 5.6 and the editor wont open. The shaders work fine, but again, I can't edit anything or create anything with Shader Forge. Here's a recording of it not working.


Answer

Answer
Fixed

Thanks for finding this out! This has been an issue for a very long time, and nobody had ever really found a consistent way to get Unity to download the correct one. I presume it works now?

+1

So the asset store thought I had the latest version. I actually didn't have the latest version and Unity wouldn't let me update because it thought everything was up-to-date. I had to delete the local asset cache under C:\Users\XXX\AppData\Roaming\Unity\Asset Store-5.x so that I could update without Unity thinking I already had the most recent version installed.

Answer
Fixed

Thanks for finding this out! This has been an issue for a very long time, and nobody had ever really found a consistent way to get Unity to download the correct one. I presume it works now?

I want to clarify for anyone searching for the solution to this problem in Unity 2017. The Asset Store is finding an old version in the cache folder instead of downloading the latest (currently v1.38) On a Mac, you need to navigate to Users\XXX\Library\Unity\Asset Store-5.x and delete the folder "Joachim Holmr". You can then download Shader Forge from the Asset Store normally and it will install and open. Many thanks to Keenan Woodall for finally solving this.