0

Can't permanently turn off #pragma only_renderers

behealed 3 months ago 0

If you uncheck all the options for Target Renderers in the shader settings, it compiles successfully without adding the #pragma only_renderers line to your shader code. That's great.


However, if you then open the shader again in shader forge, it changes your settings and adds a checkmark (without asking me) to the following options:


  • Direct3D 9
  • Direct3D 11 & 12
  • OpenGL Core
  • Open GL ES 2.0

Please fix this so that it does not automatically modify my shader settings. 


Again, just to be clear, it is automatically adding a checkmark to those 4 options without asking me.