+1
Fixed
emi 1 year ago • updated by Joachim Holmér (Developer) 3 months ago 16

We've upgraded our project to Unity 5.5 but Shaderforge does not work anymore. Here are the errors we get when trying to launch:


NullReferenceException: Object reference not set to an instance of an object

ShaderForge.SF_Editor.OnDestroy ()
UnityEditor.EditorWindow:Close()
ShaderForge.SF_Editor:Update()
UnityEditor.EditorApplication:Internal_CallUpdateFunctions()


and


AmbiguousMatchException: Ambiguous matching in method resolution

System.Reflection.Binder.FindMostDerivedMatch (System.Reflection.MethodBase[] match) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/Binder.cs:106)
System.MonoType.GetMethodImpl (System.String name, BindingFlags bindingAttr, System.Reflection.Binder binder, CallingConventions callConvention, System.Type[] types, System.Reflection.ParameterModifier[] modifiers) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System/MonoType.cs:245)
System.Type.GetMethod (System.String name, BindingFlags bindingAttr) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System/Type.cs:787)
ShaderForge.SF_PreviewWindow.SetupPreview ()
ShaderForge.SF_PreviewWindow..ctor (ShaderForge.SF_Editor editor)
ShaderForge.SF_Editor.InitializeInstance (UnityEngine.Shader initShader)
ShaderForge.SF_Editor.Init (UnityEngine.Shader initShader)
ShaderForgeMaterialInspector.OnInspectorGUI () (at Assets/ShaderForge/Editor/InternalResources/Inspectors/ShaderForgeMaterialInspector.cs:85)
UnityEditor.InspectorWindow.DrawEditor (UnityEditor.Editor editor, Int32 editorIndex, Boolean rebuildOptimizedGUIBlock, System.Boolean& showImportedObjectBarNext, UnityEngine.Rect& importedObjectBarRect) (at /Users/builduser/buildslave/unity/build/Editor/Mono/Inspector/InspectorWindow.cs:1233)
UnityEditor.DockArea:OnGUI()
Will this be fixed soon ? thanks


Answer

+2
Answer
Fixed

This has now been fixed in 1.30, which will release in a few minutes

Under review

Shader Forge doesn't support betas in general, so this is expected at the moment I'm afraid

+1

I'm using 5.5.0b6 for HoloLens development. I just bought ShaderForge and got the same error. Is it possible to get a version built for this beta could I can use it in this environment?

Technically, I'm not sure if shader forge even support 5.4 yet :)

Package has been submitted using Unity 4.5.0, 5.0.0, 5.1.0, 5.2.0, and 5.3.0 to improve compatibility within the range of these versions of Unity.

5.4 is supported, but was submitted through 5.3 because they're compatible so far

I'v just bought Shader Forge today, and got same issue, hope you guys help. I need Unity 5.5 features so do not want to get back. Thanks!

Joachim, can you fix this? This does not seem difficult, and we need Shader Forge to work.

If it's a quick fix I'll push it out with SF 1.3, taking a look at it soon

Unity is pushing 5.5 beta hard since Unity Unite and the VR and collaboration support in the latest beta copies. For a lot of things, reverting back to 5.4 release isn't a viable option. Can 5.5 beta support be a priority?

also just bought Shader Forge hoping to use it with 5.5 beta. Is there an ETA for that quick fix?

+1

I might be able to release it tomorrow - I'll look into it

thanks Joachim that would be awesome!

+2
Answer
Fixed

This has now been fixed in 1.30, which will release in a few minutes

I'm currently using 5.5.0p4 with SF v1.32 and I'm still having this happen everytime I try and run SF. Any thoughts? I've made sure to delete all old SF files from the project first before importing v1.32

Same problem as Matt! 1.32, only I am using 5.5.0f3

Using Unity 5.6.1f1, Shaderforge 1.37, I can't open ShaderForge window, gives null ref errors in console.

Can't go back to earlier version of Unity either. I think this is some weird issue with my system - as duplicate settings on another PC, work fine.

Seems likely that it might be downloading an older version than expected. Be sure to do a clean install, which may help:

http://acegikmo.com/shaderforge/faq/?Q=erroronnewversion#erroronnewversion