0

Opacity clip material renders black on 2017.2 for iOS

baroquedub 1 month ago • updated 2 weeks ago 1

I've updated a project from Unity 5.3.4 to 2017.2.1 for both Android and iOS. Works fine on Android, but on iOS the ShaderForge materials I've created (fairly simple cutout materials) render as completely black. 

I've tried deleting ShaderForge and just copying the working shader file from the working 5.3.4 project, but that also doesn't work.


Using ShaderForge 1.38. No errors in the console. I have iOS Metal ticked in the Shader target renderers (Shader settings).

The ShaderForge window displays the materials correctly but the editor (and builds) render a black opaque material:

Not working on 2017.2.1Not working on 2017.2.1
Working on 5.3.4Working on 5.3.4














Is this a known bug or is there an iOS specific setting in the newer Unity that I don't know about that also needs to be enabled? 

Player settings are a bit different to 5.3.4. Here's what I have for 2017.2:


Any help very much appreciated.

Finally worked out what the problem was... nothing to do with ShaderForge. 


For some unexplained reason, the project on my Mac (copied from the PC version) had defaulted to using a Vertex Lit rendering path. I worked it out by going into the ShaderForge example scene and noticing that all of the shaders were displaying black materials, not just mine. So I knew the problem had to be an Editor setting. 


Changing to Forward, sorted it out.